首页技术文章正文

Laravel框架要开启哪些必要的扩展?Laravel安装

更新时间:2022-05-27 来源:黑马程序员 浏览量:

在安装Laravel框架前,需要确保在php.ini中打开必要的扩展:

extension=openssl
extension=pdo_mysql
extension=mbstring

运行Laravel框架还需要PHP内建扩展的支持,默认已经开启,使用php-m命令检查是否已经开启:

bcmath
ctype
json
tokenizer
xml


使用Composer安装Laravel框架

Laravel5.8框架的安装方式:

1.通过Laravel安装器进行安装。

2.通过Composer安装。

Laravel框架安装命令:

composer create-project --prefer-dist laravel/laravel laravel 5.8.*

·create-project表示创建项目

·--prefer-dist表示以压缩的方式下载

·laravel/laravel是框架在Composer的默认包仓库网站中的包名

laravel表示将框架下载到laravel目录中

5.8.*是版本号,表示安装5.8系列的最新版本

由于Composer的资源库packagist是国外网站,在国内访问速度会很慢,可以从"Packagist中国全量镜像”获取缓存数据,具体命令如下:

composer config -g repo.packagist composer https://packagist.phpcomposer.com

取消获取缓存数据的命令:

composer config -g --unset repos.packagist

Laravel安装成功效果图:

1653637633227_Laravel安装成功效果图:.png

安装成功后,尝试访问Laravel框架:

1653637823762_63.png

更新Laravel框架命令:

composer update laravel/framework

上述命令执行后,会更新框架至最新版本。


分享到:
在线咨询 我要报名